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1 Connecting to RoviSys OPC90 (Turbo) 

 

Follow these steps to connect DBDOC to your CIU using RoviSys OPC90 (Turbo): 

1. Install RoviSys OPC90 (Turbo) on a computer that connects to a CIU. 
2. Connect RoviSys OPC90 (Turbo) to your CIU. 
3. Connect CIUMon to RoviSys OPC90 (Turbo). 
4. Set up RoviSys OPC90 (Turbo) to accept connections from any programs CIUMon is sharing the CIU 

with (such as WinCAD or Composer). 

 Note: These instructions are for RoviSys OPC90 (Turbo) version 7.2 or later. If you are using an older 
version of RoviSys OPC90 (Turbo), we recommend you upgrade. If you must connect CIUMon to an older 
version of RoviSys OPC90 (Turbo), contact G.Michaels Consulting for instructions. 
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1.1 Installing RoviSys OPC90 (Turbo) 
A trial version of RoviSys OPC90 (Turbo) is included with DBDOC. The installer for the trial version is located in 
either C:\Program Files\DBDOC\PROGRAMS\RoviSys\ orC:\DBDOC\CIUMON\Programs\RoviSys\, 
depending on how CIUMon was installed. 

 Note: The RoviSys OPC90 (Turbo) demo will run for up to two hours per day. It expires permanently and 
stops working one year after it is released. The demo on the DBDOC install DVD may have expired since the 
DVD was made. To get the newest and best version of the demo, download it 
from http://www.rovisys.com/Products/ICSP_opc_server_for_bailey.aspx. There is also a link to the RoviSys 
OPC90 (Turbo) demo download page on http://www.gmcl.com/downloads. 

To continue using RoviSys OPC90 (Turbo), you will need to purchase a license from RoviSys or G. Michaels 
Consulting.  

 Note: You may need to uninstall the demo version of RoviSys OPC90 (Turbo) when upgrading to the full 
version. Upgrading to a newer version of RoviSys OPC90 (Turbo) may also require you to uninstall the old 
version. Before uninstalling RoviSys OPC90 (Turbo), we recommend backing up your configuration: in RoviSys 
OPC90 (Turbo), on the File menu, click Save As and save a copy of the configuration file to a backup folder. 

1.2 Connecting RoviSys OPC90 (Turbo) to a CIU 
1. On RoviSys OPC90 (Turbo)'s File menu, click Open. Open DBDOC.cfg, which is in C:\Program 

Files\OPC90 Server\CFG if RoviSys OPC90 (Turbo) is installed in the default location. 
2. Right-click CIU in the left-hand pane, then click Properties. 
3. In the Primary Port list, click the COM or SCSI port that is connected to the CIU. 

 Note: If you are using RoviSys OPC90 (Turbo) on a computer with EWS software, you might want 

to move the CIU to a different port to avoid changing the EWS software configuration. 

4. Make any other changes you need, in order configure how RoviSys OPC90 (Turbo) communicates 
with your CIU. Click OK. 

5. If the CIU is connected to a COM port, set up that port. On the Edit menu, click Ports. In the Port list, 
click the port that is connected to the CIU. Set the baud rate and other settings to match the CIU. 
Click OK. 

 Note: RoviSys OPC90 (Turbo) ports default to 19200 Baud with other settings that are normally 

correct. 

6. If you want to log data, right-click CIU and select each of the first four logging options. 
7. On the File menu, click Save. 

 Note: If you are using RoviSys OPC90 (Turbo) on a computer with User Account Control (UAC) 

enabled, you may not be able to save the configuration in the default folder. Choose another folder in 

which to save the configuration. 

http://www.rovisys.com/Products/ICSP_opc_server_for_bailey.aspx�
http://www.gmcl.com/downloads�
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8. Start the connection to the CIU to make sure it works: on the View menu, click Monitor. After a 
moment, the text "CIU: ONLINE" will appear in the RoviSys OPC90 (Turbo) status bar. You must 
see MyRing and MyNode having non-zero values, except for Plant Loop, in which case MyRing will 
be zero. 

To configure RoviSys OPC90 (Turbo)'s communications with your CIU: 

 In RoviSys OPC90 (Turbo), right-click CIU in the left-hand pane, then click Properties. The Device 
Properties window appears. 

For most people using DBDOC, we recommend that you: 

 Change the Import exception report request rate to 60000 ms, unless you are using OPC tags. 
 Select the Enable Turbo Polling check box. 
 Select the Non-keyed output polling check box. 
 Select the Enhanced Analog Precision check box. 

 

Normally, programs like Composer and DBDOC must get data from your system one block at a time, but "turbo 
mode" allows RoviSys OPC90 (Turbo) to fetch multiple blocks at once. Using turbo mode, you can get data 
more quickly, while reducing the load on your system. 

If you are having problems getting data with turbo mode, please contact G. Michaels Consulting for help. We 
will work with RoviSys to make sure that you can get data reliably while benefiting from turbo mode's higher 
speeds and reduced load on your system. Meanwhile, to make sure that you are always able get data, you can 
temporarily disable turbo mode. 

To disable turbo mode: 

 Clear the Enable Turbo Polling box. 
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To enable turbo mode: 

 Select the Enable Turbo Polling box. 

Depending on how much data is being asked for, RoviSys OPC90 (Turbo) can make multiple requests for data 
at once by using different "keyed" requests. However, you can usually get data more quickly if RoviSys OPC90 
(Turbo) is making only one request at a time. So, for most situations, we recommend setting RoviSys OPC90 
(Turbo) to make only one request at a time by selecting the Non-keyed output polling box. 

1.3 Methods of connecting CIUMon to RoviSys OPC90 (Turbo) 
There are two ways to connect CIUMon and RoviSys OPC90 (Turbo): 

 RoviSys OPC90 (Turbo) virtual ports are easy to set up and provide high data rates. If RoviSys 
OPC90 (Turbo) and CIUMon are on different computers, they can still be connected with RoviSys OPC90 
(Turbo) virtual ports through the network. RoviSys OPC90 (Turbo) virtual ports require RoviSys OPC90 
(Turbo) 7.2 or newer and CIUMon 10.4 or newer. 

 Serial ports are generally harder to set up and slower. Some system managers may choose to use 
serial ports if RoviSys OPC90 (Turbo) and CIUMon are on different computers, in order to keep OPC data 
off the network. Serial ports can also be used with older versions of RoviSys OPC90 (Turbo) and CIUMon. 

1.4 Connecting to RoviSys OPC90 (Turbo) with virtual ports 
To connect CIUMon to RoviSys OPC90 (Turbo) by using RoviSys OPC90 (Turbo) virtual ports: 

1. Configure the virtual ports in RoviSys OPC90 (Turbo) 
2. Set up CIUMon to connect to the RoviSys OPC90 (Turbo) virtual ports 

To set up RoviSys OPC90 (Turbo): 
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1. In RoviSys OPC90 (Turbo), stop the connection to the CIU: on the View menu, clear 
the Monitor check mark. 

2. Expand CIU in the left-hand pane. Right-click DBDOC, then click Properties. 
3. Select Virtual port connection. 
4. In the Port list, select a different port from the one the CIU is using. 
5. Select Read only operation and Allow R4. 
6. Click OK. 
7. On the File menu, click Save. Then, start the connection to the CIU: on the View menu, click Monitor. 

To set up CIUMon: 
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1. On CIUMon's Options menu, click Settings. Choose a UDP port, and select your CIU type. 
2. Click the Communication Modes tab. Select Connect to RoviSys OPC90 (Turbo) and via virtual 

port connection. 
3. Type the IP address or hostname of the computer running RoviSys OPC90 (Turbo) in the RoviSys 

computer name or IP address box. 
4. If you changed the name of the CIU or DBDOC blocks in RoviSys OPC90 (Turbo)'s left hand pane, 

change the Device / MUXCIU block name box to match. 
5. If you know that any of the other settings need to be changed for your setup, change them now. 

Usually the defaults are fine. 
6. Click OK to close the Options window. Then, make sure you can get data from your CIU. 
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1.5 Connecting to RoviSys OPC90 (Turbo) with serial ports 
To connect CIUMon to RoviSys OPC90 (Turbo) by using serial ports: 

1. Set up a pair of serial ports on your computer 
2. Configure RoviSys OPC90 (Turbo) to provide data to one port 
3. Configure CIUMon to connect to the other port 

To set up the serial ports: 

1. If RoviSys OPC90 (Turbo) is running, exit RoviSys OPC90 (Turbo): on the File menu, click Exit. 
2. Connect two serial ports with a null-modem cable for CIUMon and RoviSys OPC90 (Turbo) to 

communicate with each other through. RoviSys OPC90 (Turbo) will connect to one of these ports, and 
CIUMon will connect to the other. 

3. Write down which ports you set up and which program you plan to connect to each of them. 

 Notes: 

 Very old versions of RoviSys OPC90 (Turbo) cannot connect to serial ports above COM9, but 

you can use low port numbers for RoviSys OPC90 (Turbo) and higher ones for CIUMon in that 

case. 

 If RoviSys OPC90 (Turbo) and CIUMon are on the same computer, and it does not have a 64-

bit operating system, you can use virtual serial ports. 

 If RoviSys OPC90 (Turbo) and CIUMon are on different computers or on a computer with a 

64-bit operating system, and there are not enough serial ports, you can add more ports with 

an internal interface card or a usb-to-serial converter. Alternately, you can use a third-party virtual 

serial port program. 

To set up RoviSys OPC90 (Turbo): 
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1. Start RoviSys OPC90 (Turbo). 
2. Expand CIU in the left-hand pane. Right-click DBDOC, then click Properties. 
3. In the Port list, click the port that you set up for RoviSys OPC90 (Turbo). Select Read only 

operation and Allow R4. Click OK. 
4. On the Edit menu, click Ports. In the Port list, click the port that RoviSys OPC90 (Turbo) was set to 

use in the previous step. Set the baud rate to 57600. Click OK. 115200 is overly vulnerable to ambient 
interference and should not be used. 

5. On the File menu, click Save. Then, start the connection to the CIU: on the View menu, click Monitor. 

To set up CIUMon: 
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1. On CIUMon's Options menu, click CIUMon Settings. Choose a UDP port, and select your CIU type. 
2. Click the Communication Modes tab. Select Connect to RoviSys OPC90 (Turbo) and via serial 

port. (Connect directly through serial port can be used instead, but there is some loss of 
performance using that option.) 

3. Click the Comm and Flow Control Settings tab. Select the serial port you set up earlier for CIUMon 
in the Serial Port list. In the Baud Rate list, click the baud rate of the serial port connected to the CIU. 

 Note: If you are using virtual serial ports, this setting doesn't matter. 

4. If you know that any of the other settings need to be changed for your setup, change them now. 
Usually the defaults are fine. 



Using OPC90 with DBDOC - Bailey™ WinCAD or Composer 
 

Page 
10 

 

 

5. Click OK to close the Options window. Then, make sure you can get data from your CIU. 

1.6 Adding serial ports to your computer 

 

RoviSys OPC90 (Turbo) may connect to CIUMon or your EWS software through a serial line. To do so, 
RoviSys OPC90 (Turbo) and the other program must each have a COM port, and these ports must be 
connected. In many cases, if RoviSys OPC90 (Turbo) and the other program are running on the same 
computer, they can connect through virtual serial ports rather than real serial ports. 

 Instead of using serial ports, CIUMon can connect to RoviSys OPC90 (Turbo) using RoviSys OPC90 
(Turbo) virtual ports. 

 On 32-bit platforms, you can connect your EWS software to RoviSys OPC90 (Turbo) using virtual 
serial ports included with DBDOC. 

 The included virtual serial ports do not work on 64-bit Windows platforms (including Windows 7). To 
add serial ports to one of these platforms, use a usb-to-serial converter, or better, use internal serial 
ports on the motherboard or install a PCI serial card. Alternately, you can use a third-party virtual serial 
port program. 

To set up virtual serial ports: 
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1. On the CIUMon Options menu, click Virtual Serial Port Setup. The Virtual Port Setup program will 
open. 

2. On the Virtual Port Setup Options menu, click VSP Configuration. 
3. In the Virtual Serial Port Creation list, click any port. Hold down CTRL and click a second port. 

Click Create Now. The two ports that were selected will disappear from theVirtual Serial Port 
Creation list and appear in the Virtual Serial Port Deletion list. 

4. Click the Virtual-To-Virtual Connections tab. 
5. In the VSPs Available list, click the first port, then click the second port. Click Add To List. The two 

ports will disappear from the VSPs Available list, and the new connection will appear in the Virtual-
To-Virtual Connections list. 

 Note: 

 The Virtual Serial Port Setup option is disabled on 64-bit Windows platforms (including Windows 7). 
Also, they do not work on Windows 8. To add serial ports to 64-bit Windows, use a usb-to-serial converter. 
Alternately, you can use a third-party virtual serial port program. 

 If you have not run Virtual Port Setup before, it will be installed when you try to run it. You will then be 
prompted to reboot the computer. 

 The first time you set up and try to use virtual serial ports after installing them and rebooting the 
computer, you may see an Error: COMx.Read (), code 87 message in the Virtual Port Setup window. If 
this occurs, reboot your computer again -- the virtual serial ports should work fine after this second reboot. 

 If you get a Could not find OEM file error after your computer reboots, copy the file "vsp.oem" from 
the folder where CIUMon is installed to the system32 subfolder of your computer's Windows folder. 

 If you later install more physical serial ports, you should delete all of the virtual serial ports and 
connections first, then re-create them after the new physical ports are installed and working. 

To remove virtual serial ports: 

1. In Windows Explorer, browse to the PROGRAMS folder in your installation directory (this is usually in 
either C:\Program Files\GMCL\DBDOC or C:\DBDOC\CIUMON). 

2. Double-click VSPCleanup.exe and follow the instructions. 
3. If the computer was not rebooted in the previous step, reboot it now. 

To set up internal serial ports: 

1. If you are installing a new interface card to add serial ports, you will have to power down the computer 
and open it up. Identify an unused slot of the type required by the card and remove the corresponding 
cover from the back of the case. Depending on the number of ports supported by the card, you may 
also have to connect a serial port headerto the card and install it in another unused opening in the 
back of the case. 

2. Identify the serial ports you've installed: 

a. Right-click the My Computer icon on the desktop, and then click Properties. 

b. Click the Hardware tab, then click the Device Manager button. 
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c. Expand the Ports (COM & LPT) entry. The serial ports should each be listed 

as Communications Port (COMn) or mumble Serial Port (COMn), where n is the port 

number and mumble is some descriptive text. 
3. Connect two ports with a null modem cable, to provide a connection between them. 

To set up a usb-to-serial converter: 

1. Plug the converter into an available USB port on your computer. 

After a short delay, Windows will recognize and install the converter. When it has finished installing 

the converter, it will display a message in the system tray. 

2. Check that it is installed correctly: 

a. Right-click the My Computer icon on the desktop, and then click Properties. 

b. Click the Hardware tab, then click the Device Manager button. 

c. Expand the Ports (COM & LPT) entry. The new serial ports should each be listed as USB 

Serial Port (COMn), where n is the port number. 
3. Connect two ports with a null modem cable, to provide a connection between them. 

 Note: GMCL has USB-to-serial converters available for sale. Please contact G. Michaels Consulting for 
details. 

A note about USB-to-serial converters and Windows 7: 

On Windows 7 and Windows 2008 Server, USB-to-serial converters do not work as well as internal serial ports. 
They are slower and have higher error rates. In some cases, they may not work at all. You should use internal 
serial ports if possible. Alternately, you can use a third-party virtual serial port program. 

If you do use USB-to-serial converters on Windows 7 and 2008 Server, do not use speeds above 115200 bps. 

If Windows 7 or Windows 2008 Server does not automatically install your USB-to-serial converter, you will need 
to download drivers from the converter manufacturer's website. The drivers for the USB-to-serial converters 
sold by GMCL are available at http://www.vscom.de/616_download.htm. 

Third-party virtual port alternatives: 

As an alternative to RoviSys OPC90 (Turbo) virtual ports, the virtual serial port software included with DBDOC, 
or physical serial ports, you can use a third-party virtual serial port program to connect CIUMon or your EWS 
software to RoviSys OPC90 (Turbo). 

These software packages can create virtual serial ports for CIUMon or your EWS software to use for 
connecting to RoviSys OPC90 (Turbo): 

 The com0com null-model emulator is an open source virtual serial port driver that supports both 32-bit 
and 64-bit versions of Windows. Note that to use this program with 64-bit Windows, you will need a signed 
version of the com0com driver. Contact G. Michaels Consulting for information about obtaining a signed 
version of the driver. 

http://www.vscom.de/616_download.htm�
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 The Eltima Virtual Serial Port Driver is a commercial software package that can create virtual serial 
ports. It supports both 32-bit and 64-bit versions of Windows. 

1.7 Connecting other programs to RoviSys OPC90 (Turbo) 
If you are using RoviSys OPC90 (Turbo) to share a serial connection to a CIU between CIUMon and EWS 
software (such as Composer or WinCAD), you can avoid changing the EWS software settings with the 
following strategy: 

1. Move the CIU connection to a different serial port, and connect RoviSys OPC90 (Turbo) to that serial 
port. 

2. When you set up RoviSys OPC90 (Turbo) to accept connections from the EWS software, connect a 
null cable between the serial port that the CIU was connected to and a third serial port. 

3. Then, have RoviSys OPC90 (Turbo) use the third serial port to communicate with the EWS software. 
The EWS software will connect to RoviSys OPC90 (Turbo) through the null cable, using the same port 
as before. 

A side benefit of this approach is that you can reconnect the CIU directly to the EWS simply by moving the 
cable back. If the computer does not have the extra serial ports you need for this approach, you can add serial 
ports with an internal interface card or a usb-to-serial converter. 

To connect other programs to RoviSys OPC90 (Turbo): 

1. If RoviSys OPC90 (Turbo) is running, exit RoviSys OPC90 (Turbo): on the File menu, click Exit. 
2. Set up two connected (real or virtual) serial ports for RoviSys OPC90 (Turbo) and the other program to 

communicate with each other through. Write down the two port numbers. RoviSys OPC90 (Turbo) will 
connect to one of these ports, and the other program will connect to the other one. 

 Note: If you moved the CIU connection so you wouldn't have to change settings in the EWS 

software, then use a connection between the serial port it was originally using and another real serial 

port. 

3. Start RoviSys OPC90 (Turbo) and open the saved configuration. 
4. Right-click CIU in the left-hand pane, then click New Block. 
5. Type a name for the block in the Name box (e.g. WinCAD). 
6. In the Block Type list, click MUXCIU. 
7. In the Port list, click the port that you set up for RoviSys OPC90 (Turbo). Click OK. 
8. On the Edit menu, click Ports. In the Port list, click the port that you set up for RoviSys OPC90 (Turbo) 

again. Set a baud rate that your EWS software supports (typically 19200). Click OK. 
9. Start the connection to the CIU: on the View menu, click Monitor. 
10. Set up the other program to connect to the port you set up for it. 

 

http://www.eltima.com/products/vspdxp/�
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